Overview
Server-workload connectivity has been interrupted preventing the completion of workload activity. Agent Proxy logs surface the following error message, "ERROR aembit_proxy::protocols::tcp_passthrough - Could not connect to the server workload: Connection refused (os error 111)"
Relates To
- Server Workload
- Workload Events
- Access Policy
Causes
The error signature reflects a range of entry points for remediation. We recommend reviewing these areas of interest to validate your configuration, ingress/egress setup, and environmental network activity.
- Access Policy
- Policy configuration - Client Workload, Trust Provider (optional), Credential Provider, Server Workload
- Server Workload
- Target Destination
- IP, Port
- Hostname
- Agent Proxy
- Variables - Review values
- Environment
- Network - Activity spikes, updates or maintenance
Solution
- To investigate, we should start by enabling 'debug' log level. See details below in the related Knowledge base article, here.
- Debug level tracing provides granular details at various phases of Agent Proxy or Agent Controller activity.
- We recommend reviewing communication between Agent Proxy and Agent Controller to ensure Edge Components are operating as expected.
- If Agent Proxy registration is failing, review the technical information found Troubleshooting Agent Proxy Registration
- To analyze the behavior between your Client Workload and Server Workload, we detailed steps on troubleshooting an Access Policy outlined in the following article, Troubleshooting an Access Policy.
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- We recommend reviewing
- The checks performed by our Troubleshooter tool
- Reviewing the accuracy of data fields populated for each component in your access policy
- Confirming Network activity to target Server Workload for any erroneous activity
- We recommend reviewing
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